git stopped working with 1.7.1

Tomas Staig
Tue Sep 28 03:45:00 GMT 2010

survivant wrote:
> Does anyone one have an answer for this problem ?  (I saw lot of threads in
> different forums.. but never an answer.)
> I'm trying to clone a repository from my computer to my computer.  I,m using
> cygwin 1.7.   I,m able to clone all my others projects without problems. 
> This project is 900k.. and the others are better than that.
> I have no idea what going on.  I deleted the project and repush it.. always
> the same problems.
> $ GIT_TRACE=1 git clone git@localhost:SmallProject.git
> trace: built-in: git 'clone' 'git@localhost:SmallProject.git'
> Cloning into SmallProject...
> trace: run_command: 'ssh' 'git@localhost' 'git-upload-pack
> '\''SmallProject.git'\'''
> DEBUG:gitosis.serve.main:Got command "git-upload-pack 'SmallProject.git'"
> DEBUG:gitosis.access.haveAccess:Access check for 'jerabi' as 'writable' on
> 'SmallProject.git'...
> DEBUG:gitosis.access.haveAccess:Stripping .git suffix from
> 'SmallProject.git', new value 'SmallProject'
> 'jerabi' in 'gitosis-admin'
> 'jerabi' in 'dev_jerabi'
> DEBUG:gitosis.access.haveAccess:Access ok for 'jerabi' as 'writable' on
> 'SmallProject'
> DEBUG:gitosis.access.haveAccess:Using prefix 'repositories' for
> 'SmallProject'
> DEBUG:gitosis.serve.main:Serving git-upload-pack
> 'repositories/SmallProject.git'
> trace: run_command: 'index-pack' '--stdin' '-v' '--fix-thin'
> '--keep=fetch-pack 6900 on jerabi-THINK'
> trace: exec: 'git' 'index-pack' '--stdin' '-v' '--fix-thin'
> '--keep=fetch-pack 6900 on jerabi-THINK'
> remote: Counting objects: 344, done.
> trace: built-in: git 'index-pack' '--stdin' '-v' '--fix-thin'
> '--keep=fetch-pack 6900 on jerabi-THINK'
> remote: Compressing objects:  58% (134/230)
> remote: Compressing objects: 100% (230/230), done.
> fatal: The remote end hung up unexpectedly
> fatal: early EOF
> fatal: index-pack failed
> jerabi@jerabi-THINK ~/workspaces/test
> $
> $ git --version
> git version
Don't have a clue of why this happens (some people say it is because of 
openssh, that if you change it for putty's implementation it works well) 
but when that happens to me (while pulling, never tried with clone) I 
just try a couple of times until it succeeds:

for (( i=0 ; i < 100 ; i++ )); do git pull; done

works all the time for me... try something similar but with "git clone 
..." of course.

And well, I'm working with a 4+GB repository, so I'm really thankful 
that the clone worked right away.

I know it's not the best solution, but if it works... it's good enough 
as a temporal workaround.
Hope it works for you.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list