Unable to disown process

Andrew DeFaria Andrew.DeFaria@tellabs.com
Wed Jul 6 17:24:00 GMT 2011


I have the following script that I use to tunnel nntp traffic:

    #!/bin/bash
    nohup ssh -NL 1119:news.mozilla.org:119 \
          -L 2119:news.gmane.org:119 \
          -L 3119:nntp.perl.org:119 \
       andrew@defaria.com > /dev/null 2>&1 &

    disown

If I run this script it works fine and I'm tunneled. The problem is I 
cannot exit the terminal in which I invoked this script. When I attempt 
to do this the terminal hangs. I can close the terminal (mintty BTW) 
forcefully and the ssh session remains but it was my understanding that 
disown should allow you to exit the current shell with the 
backgrounded/disowned process continuing to run. In fact I tested this 
on RHEL and it worked as expected. What's up with Cygwin?
-- 
Andrew DeFaria <http://defaria.com>
Part of the inhumanity of the computer is that, once it is competently 
programmed and working smoothly, it is completely honest. - Isaac Asimov


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list