"cant commit memory for stack" error with perl

Corinna Vinschen corinna-cygwin@cygwin.com
Mon Apr 2 14:45:00 GMT 2012

On Apr  2 16:30, Noel Grandin wrote:
> On 2012-04-02 12:19, Corinna Vinschen wrote:
> >Just download cygwin1-20120401.dll.bz2, bunzip it, chmod +x it,
> >and then replace cygwin1.dll in /bin with that file from Windows
> >Explorer. That's it
> Thanks for that suggestion.
> Tried it. Also tried rebooting.
> Also tried disabling DEP and ASLR.
> Still no joy.
> Sigh...

If you can strip your perl script to the bare minimum necessary to
reproduce the issue, I can take a look if I can reproduce it.

Oh, and, where is your perl.exe based to?  In other words, what does

  $ objdump -h /bin/perl.exe | grep '\.text'

print?  (objdump is part of the binutils package).

If it's *not*


but rather something like


call `rebase -b 0x400000 /bin/perl.exe'
and try again.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list