"dst_lib_init: openssl failure" after yesterday's update

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Thu Apr 5 20:17:00 GMT 2012

On 4/5/2012 5:57 AM, Adrian Fita wrote:
> Hi.
> After yesterday update I noticed that when I run host or dig, they
> give the error "dst_lib_init: openssl failure" (some other commands
> which use the openssl library may fail like this also). I did a reboot
> and also did an update today, which installed "_autorebase-000030-1"
> and "base-cygwin-3.1-1", but still no change.
> I also reinstalled base-cygwin, cygrunsrv, cygutils, cygwin, bind,
> libopenssl098, libopenssl100, but no change.

Works for me:

$ host localhost
localhost has address

Just updated all my locally installed packages and included 'bind'.  I
guess your next step is to provide a full problem report if you haven't
been able to solve this.

> Problem reports:       http://cygwin.com/problems.html



A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list