[1.7.13] STATUS_ACCESS_VIOLATION when running cygwin programs in NAnt scripts

Andre Loker mail@andreloker.de
Sat Apr 7 08:48:00 GMT 2012


On a new system with a clean 1.7.13 installation (CYGWIN_NT-6.1-WOW64 
rs200313 1.7.13(0.260/5/3) 2012-04-05 12:43 i686 Cygwin) I'm getting 
STATUS_ACCESS_VIOLATIONs whenever I try to run any cygwin program as 
part of a NAnt* build script.

E.g. if I try to execute:
c:\cygwin\bin\bash.exe --login /cygdrive/c/Backup/syncvia.sh

I get

      [exec] C:\Backup>c:\cygwin\bin\bash.exe --login 
      [exec]       0 [main] bash 3468 exception::handle: Exception: 
      [exec]     774 [main] bash 3468 open_stackdumpfile: Dumping stack 
trace to bash.exe.stackdump

Here's the stackdump file:
Exception: STATUS_ACCESS_VIOLATION at eip=61029E40
eax=00000000 ebx=0028ABCC ecx=20000668 edx=61188348 esi=00000000 
ebp=00000000 esp=0028AB40 program=c:\cygwin\bin\bash.exe, pid 3732, 
thread main
cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
Stack trace:
Frame     Function  Args
End of stack trace

I have tried to execute other cygwin programs with similar results.

However, if I run the cygwin programs from a cmd prompt or in a shell 
everything works fine.
Also, on another machine that uses the same script but runs
CYGWIN_NT-6.1-WOW64 CT50796 1.7.11(0.260/5/3) 2012-02-24 14:05 i686 Cygwin
everything works fine, too.

I already tried a rebaseall without success.

Any idea what could cause this behavior?

Both systems run Windows Server 2008 R2 Datacenter btw.



Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list