Can RPM packages be installed into Cygwin?

De-Jian Zhao
Sun Apr 8 03:10:00 GMT 2012

On 2012-4-7 16:12, marco atzeri wrote:
> On 4/7/2012 9:40 AM, De-Jian Zhao wrote:
>> Dear all,
>> I noticed that there is a command - rpm - under Cygwin 1.7. Does that
>> mean RPM packages can be installed into Cygwin?
>> I tried to install ncbi-blast-2.2.26+-3.i686.rpm (see:
>> ) into
>> Cygwin 1.7.13 with the command "install -i
>> ncbi-blast-2.2.26+-3.i686.rpm". However, error message appeared as
>> below. I tried to search for the missing libs using the setup.exe of
>> Cygwin. It seems that some of them were not present, such as,
>>,,, and Where can I get these
>> libs? Thanks!
>> $ rpm -i ncbi-blast-2.2.26+-3.i686.rpm
>> error: Failed dependencies:
>> /usr/bin/perl is needed by ncbi-blast-2.2.26+-3
>> is needed by ncbi-blast-2.2.26+-3
>> is needed by ncbi-blast-2.2.26+-3
> {cut]
> ...isn't it?
> from cygwin website (first page):
> Cygwin is not:
> -    a way to run native Linux apps on Windows. You must rebuild your 
> application
>      from source if you want it to run on Windows.
> -    a way to magically make native Windows apps aware of UNIX® 
> functionality like
>      signals, ptys, etc. Again, you need to build your apps from 
> source if you want
>      to take advantage of Cygwin functionality.
> Regards
> Marco
Thanks, Marco. I was not trying to run a native linux apps, and instead 
tried to rebuild the app from source. The BLAST software provides the and scripts under the dirctory of 
So I think it is possible to run the software under cygwin. However, the 
compilation stopped at "checking for python", even if python was 
installed. That's to say, I installed the latest python and the 
compilation could find it, but the compilation tried to search for 
python2.3 and 2.4 further, and stopped when searching for 2.4.

What I am concern is that whether the i686.rpm indicates it is prepared 
for cygwin. As you know, when you run "uname -smo" , you can get 
something like this "CYGWIN_NT-5.1 i686 Cygwin". I think the package 
ncbi-blast-2.2.26+-3.i686.rpm is for Cygwin. Is that right? Has anyone 
ever succeeded in installing a RPM package into cygwin using "rpm -i *rpm"?


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list