Interesting gotcha: http + vim-common + maybe Symantec Endpoint Protection

Tim McDaniel
Wed Apr 11 19:27:00 GMT 2012

I had something interesting happen to me and wanted to mention it,
though perhaps it's in the FAQ and I've just not noticed it.

Short form: if downloading a file freezes or fails, switching your
setup server from http: to ftp: (or perhaps vice versa) may help.

The symptom was that, for a few months, I was unable to download the
latest version of vim-common -- it would hang, either partway thru or
at the start.  The mirror was, so

     vim-common-7.3.447-1.tar.bz2 from

     0 % (0k/1k) 0.0 kB/s

     Download Incomplete. Try again?

Before, I thought that maybe just xmission was hosed.  I tried another
host: same result.  I got tired of it and just uninstalled vim and
vim-common just so I didn't have to re-deselect them on each update.

Today, I wondered whether it was a file permission problem, so I
renamed -- same

I then suddenly thought to try the ftp: version of the same mirror, as
I had been using the http: version.  Success!

My system has, as its antivirus, Symantec Endpoint Protection.
I checked the logs and found nothing.  However, I might not be looking
in the right place, or for all I know, maybe there is scanning further
up like on the $ORKPLACE Internet gateway and thus I can't possibly
see it or control it.  The FAQ suggests turning off anti-virus (2.8 My
computer hangs when I run Cygwin Setup!), but that is NOT permitted
(or even possible) for a user at $ORKPLACE.

Tim McDaniel,

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list