Process Substitution / Named Pipes in cygwin 1.7.11-1

Gregory M. Turner gmt@malth.us
Wed Apr 11 19:48:00 GMT 2012


----- Original Message (cgf) -----
> On Wed, Apr 11, 2012 at 06:17:40PM -0000, Gregory M. Turner wrote:
> >----- Original Message (Me) -----


> >  $ diff -u <(echo foo) <(echo bar)
     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ concrete detail


> I suspect that it probably about as irritable as certain people get when
> "bug reports" are couched in colorful adjective-laden language without
> any actual concrete details.

Eh?  There's been no bug report.  I was just sharing some casual
observations in response to another post.

To be clear:

The above diff command has no output.  The output is supposed to be along the lines of:

--- /dev/fd/63  2012-04-11 11:44:02.283689675 -0700
+++ /dev/fd/62  2012-04-11 11:44:02.283689675 -0700
@@ -1 +1 @@
-foo
+bar

The failure is reproducible on the latest mainline distribution running
on my workstation.  It also occurs exactly the same way in a very different
roll-your-own environment I have immediate access to, also on my workstation.

I suppose I could have mentioned that my box is:

CYGWIN_NT-6.1-WOW64 1.7.13(0.260/5/3) 2012-04-05 12:43 i686 unknown unknown Cygwin

That's all I know.  I'm well aware that more effort will probably be required on
my part if I'm to meaningfully contribute to solving the problem.  As I
stated: I don't have time to debug it any further.  If you don't like that fact, I
invite you to ignore me and wait a day or two, after which I've already promised to
make some time to look into it further.

Sheesh, you win I guess: I'm now as frustrated as you apparently are.
Shall we move on or just have a big stupid flame-war?  I'm game either way.

-gmt

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list