1.7.11-1 Update returns non-zero exit codes for coreutils

Brian Wilson wilson@ds.net
Thu Apr 12 23:43:00 GMT 2012

Nothing I tried could bring the Cygwin package back to life.  Even trying to 
install the latest new release didn't work.  I finally just removed the 
application and downloaded everything again.

I now have the 1.7.13-* release available and working.  I made a copy of the 
download tracking files (I don't know the real name for these files) and was 
able to diff the new basic download package against the previous download and 
make sure I got all the packages I had previously had.

With just a little work, I was able to get everything.  Now I just need to 
setup the apache2 server, the sshd deamon, etc.  I hope my notes are correct. 


Brian S. Wilson
---------- Original Message -----------

> >> On 3/29/2012 9:10 PM, Brian Wilson wrote:
> >>> From: Andrew
> >>>>
> >>>> I just got this exact same thing and tried re-installing coreutils
> >>>> with no effect.  Initially, I had been installing binutils, and was
> >>>> told to restart because I had left a cygwin console open during the
> >>>> install.  Interested to hear what is known about this (recent) issue.
> >>>>
> >>>
> >>> Interesting...  I didn't have any consoles open (that I remember) during
> > the
> >>> update, but I've rebooted and done an update since this issue surfaced
> > (again
> >>> with no console open) and it hasn't resolved.  I've been wondering if I
> > should
> >>> remove the C:\cygwin directories and try installing again.  I'm hoping I
> > won't
> >>> have to do something that drastic.
> >>
> >> I'd recommend making sure all Cygwin processes are stopped (including
> >> services) and try installing the cygwin and coreutils package again,
> >> along with anything else you'd like to include.  If you're still having
> >> problems, cygcheck output will be helpful in any follow-up.
> >>
> >
> >
> > So, Larry, are you talking about un-/reinstalling cygwin entirely*?  Also,
> > does cygwin dev monitor this chat in case this is a bug?  If not, is there 
> > better place to report such an issue?
> I'm suggesting reinstalling the packages in question with any other package
> you think might be affected.  Of course, it's likely that if you re-run
> 'setup.exe' now (grabbing the newest one from cygwin.com of course), 
> you'll get the newest cygwin package (1.7.12) even without asking 
> for it to be reinstalled, since a new package for it has come out 
> since your posting.
> The Cygwin development team is on this list.  This is the list to report
> issues with Cygwin usage, with the exception of Cygwin X issues 
> which should go to the cygwin-xfree list.
> > Couple of other points.  In searching some of the error codes (eg. 
> > not found" message), I also added "c:\cygwin\bin" to my PATH and created 
> > variable CYGWIN_HOME as "c:\cygwin".  This stopped the "command not found"
> > message, though ls output was still empty.
> Could be BLODA <http://cygwin.com/faq-
> nochunks.html#faq.using.bloda>.  But perhaps it makes the most sense 
> to see a problem report if you're still having difficulties after 
> trying my suggestion.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list