Installation / download issues

Richard Troy
Sat Apr 14 17:42:00 GMT 2012

...During an exchange on a completely unrelated topic:

On Sat, 14 Apr 2012, Christopher Faylor wrote:
> >>
> >> On 4/10/2012 6:15 PM, Richard Troy wrote:
> >>
> >> <snip>
> >>
> >Did that, though once again I ran into the ole cygwin update /
> >installation disaster that is <rant> based on the fact that something
> >somewhere doesn't download and the installation doesn't complete properly
> >and you have to manually figure out what didn't download, explicitly
> >download that, and then, several tries later, you get a working
> >installation. Why the cygwin population puts up with this and doesn't fix
> >the installation script is beyond my pay grade... Heck, just giving us a
> >single zip to get "everything" would be _so_ less problematic! -shrug-
> ></rant>
> If something doesn't download properly the setup.exe is not supposed to
> continue.  And, the next time you rerun setup.exe the file should be
> downloaded correctly.  Setup.exe uses md5sums to try to ensure that what
> it downloads is correct.

I have observed on not less than three completely separate occasions,
separated by several years each, that what you write above is incorrect;
that is, it has continued on in spite of some unknown error, with some
fundamental library or component not present which prevented a properly
complete installation as per what was desired. Sometimes the problem
pertains to the whole installation and you notice it right away, during
the ending phase of the installation process and on other occasions you
only notice when some package isn't working correctly.

> Maybe you found a bug in setup.exe but there is no way to know that
> since you felt compelled to waste bandwidth venting rather than calmly
> describing your problem.  If you'd care to file a proper bug report
> then it's possible that someone will look into it.

BOTH of the last times I reported this all I got were blank stares, so
please reserve your own indignation; I don't deserve it. One person had
the kindness to point out what sub-component the missing item came from. I
then tried to download the package that contained it a few times further
and got no joy, so I moved on to a different repository (mirror), it
installed OK, and I moved on. (...How am I supposed to do better when the
folks that are supposed to care just shine on the problem completely -
more than once?)

On subsequent occasions I have merely known that when an installation
hoses up (which appears to be every single time I try and download - which
was why I was seven releases behind and only upgrade when there's a damned
good reason to) I should try a different repository and usually I've had
success on the next try, or just keep going repeatedly until it actually

Never has there been a competent error message that points to the real
cause, only that some script(s) couldn't do something-or-other. Sometimes
these involve a single script - like the host setup for sshd, and
sometimes it involves all scripts, like what happened to me Tuesday night
when some ncurses library was missing. My guess is that it has nothing to
do with MD5 checksums but rather that a whole package didn't download
somehow and the installation process misses it completely. Heck, it even
thought it had installed the package in question.

I want to point out that I've seen other people - non-regulars on this
list - with echos of the problem(s) I'm telling you about now. I recall
about a month ago some fellow being told something like (paraphraised),
"oh, your system is missing xyz, go install that" and the person
responding, "ok, sure, but I thought I'd installed everything..." I
deleted that dialogue out of my inbox but recall it specifically because
of my own experience.

As you want a bug report, I think I saved the logs, so maybe that's still
possible, though I was under the impression that they got overwritten on
subsequent tries; I _think_ I may have saved the logs from the first
attempt on this latest cycle last Tuesday night. I'll try and dig into it
tomorrow AM over coffee and if it's still available, I'll log a bug. As
I'm not a Cygwin committer, is submitting here, on-list, sufficient, or
where do you want me to enter it officially? "Problem reports" url cited

> Remeber:
> Indignation != clue

Not Always, smart guy.  ... I'm very grateful for all that the community
does, but sometimes there is some valid criticism. You might temper YOUR
indignation at me; I'm a supporter and ally - as best I can be anyway. And
I've read a lot of your posts from the archives or live on the list and I
know you're earnest and mean well - please know that I am, too. Tell me
how to help and I will if I possibly can.


> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list