1.7.11: Ctrl-C does not work in bash shell (Win7)

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Tue Apr 17 14:35:00 GMT 2012

On Tue, Apr 17, 2012 at 12:14:47AM -0700, Linda Walsh wrote:
>Buchbinder, Barry (NIH/NIAID) [E] wrote:
>> Spackmann, Richard M. sent the following at Tuesday, April 03, 2012 2:18 PM
>>> When I open up a cygwin command line bash shell and I notice now that
>>> Ctrl-C does not exit out from the current command prompt to start a new
>>> one.
>>> Ctrl-C will however exit a running process.
>>> Is this to be the behavior from now on, or is a
>>> reoccurrence of the possible bug as reported in
>>> http://cygwin.com/ml/cygwin/2012-03/msg00102.html.
>>> If so, when is the next cygwin bug release due out?
>>> I am running Windows 7 and just upgraded to 1.7.11 - attached is the
>>> output of cygcheck.
>> I think that it may be bash, not cygwin.  Bash does not exit with ^C,
>> but will with ^D.
>> See SIGNALS in man bash.  (A feature, not a bug.)
>	It's not that it should exit -- but it used to abort the input
>of the current line, and give you a new one --
>	I managed to find a combination of stty settings that worked
>around it with a side effect of killing any window I press control-C
>in if a program is 'stuck'... i'm running bash inside of 'console.exe',
>and if I have a program that hangs, pressing control-c kills the prog,
>bash and the window -- well -- at least it kills it -- not an idea
>I stuck "stty echoctl ignbrk" in my .bashrc, to get the current behavior
>which results in bash reverting to it's normal behavior (controlC aborts
>current line or kills a shell script waiting for input...), with
>the side effect noted above...
>Hopefully it will get fixed...

I don't know what time warp you just stepped out of which required you to
start responding to old messages but we're actually on Cygwin 1.7.13 now.
CTRL-C works as expected both in a console window and under mintty.

If there is actually still a problem which is not related to some
strange form of extreme jet lag then it would be nice if someone
recounted the exact steps to duplicate it.  There is no need to offer
strange workarounds or hopeful thoughts.  As always, we need details.

By details I mean a non-editorialized, adjective-lite series of commands
showing the problem.

What I did was type "bash" in a command window in Windows 7 64.  Then I
typed CTRL-C.  I also typed asdef^C and got a new prompt.  I did the
same thing under mintty with the same result.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list