Problems with nfs

Fedin Pavel p.fedin@samsung.com
Tue Apr 24 07:19:00 GMT 2012


On 24.04.2012 9:27, Fedin Pavel wrote:
>
>  Also, why does nfs access appear to be so horribly slow? Loading a 
> directory with ~150 files takes about two minutes in mc. I understand 
> fork() issue, but what are problems with just reading files descriptors?
>
  I resolved the problem with slowness. This appeared to happen because 
of seteuid() error (discovered in logs). Local system account on Win7 
doesn't have token creation/change rights. I fixed this by creating own 
local user with sufficient privileges and running nfsd under this 
account. BTW, may be you should add remark about this particularity into 
nfs-server.README file? It's not obvious, because the system works, just 
very slowly. The user might think it's okay.
  But RPC problem didn't go away. I tried to run portmapd under the same 
user with no positive result. The first thing client says is:
pmap_getmaps.c: rpc problem: RPC: Unable to receive; errno = Connection 
reset by peer
  I tried to completely turn off Windows firewall, again with no effect. 
So i still have to restart portmap service after i log in into the 
system in order to get NFS working.
  And one more little but annoying thing. All files on Linux site appear 
to have owner and group id == 42949672. However access control works 
correctly (i didn't modify any Cygwin mounts and i have ACLs turned on). 
/etc/nfs/server.map is set up correctly (i guess so, because access 
control works, i can read write and execute my files). Looks like it's 
some problem with reverse mapping.

-- 
  Kind regards
  Pavel Fedin
  Expert engineer, Samsung Moscow research center


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list