Problems with nfs

Thomas Dineen
Tue Apr 24 16:15:00 GMT 2012


      Make sure both sides of the connection are running the same 
version of NFS.
Some of the issues describes here can be seen in connections where two 
NFS try to inter-operate!!!!

Thomas Dineen

On 4/24/2012 12:19 AM, Fedin Pavel wrote:
> On 24.04.2012 9:27, Fedin Pavel wrote:
>>  Also, why does nfs access appear to be so horribly slow? Loading a 
>> directory with ~150 files takes about two minutes in mc. I understand 
>> fork() issue, but what are problems with just reading files descriptors?
>  I resolved the problem with slowness. This appeared to happen because 
> of seteuid() error (discovered in logs). Local system account on Win7 
> doesn't have token creation/change rights. I fixed this by creating 
> own local user with sufficient privileges and running nfsd under this 
> account. BTW, may be you should add remark about this particularity 
> into nfs-server.README file? It's not obvious, because the system 
> works, just very slowly. The user might think it's okay.
>  But RPC problem didn't go away. I tried to run portmapd under the 
> same user with no positive result. The first thing client says is:
> pmap_getmaps.c: rpc problem: RPC: Unable to receive; errno = 
> Connection reset by peer
>  I tried to completely turn off Windows firewall, again with no 
> effect. So i still have to restart portmap service after i log in into 
> the system in order to get NFS working.
>  And one more little but annoying thing. All files on Linux site 
> appear to have owner and group id == 42949672. However access control 
> works correctly (i didn't modify any Cygwin mounts and i have ACLs 
> turned on). /etc/nfs/ is set up correctly (i guess so, 
> because access control works, i can read write and execute my files). 
> Looks like it's some problem with reverse mapping.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list