How do I build this program for Cygwin?

Sun May 6 09:22:00 GMT 2012

--- On Sun, 6/5/12, Mark Geisertwrote:

> From: Mark Geisert 
> Subject: Re: How do I build this program for Cygwin?
> To: cygwin
> Date: Sunday, 6 May, 2012, 9:46
> Marilo writes:
> > > You followed the wrong instructions.
> > 
> > The instructions - "INSTALL" said
> > 1. configure
> > 2. make
> > ..
> > 
> > But the problem is "configure" didn't exist.
> Two things: 1st, Whoever wrote the INSTALL was sloppy and
> should have said
> "./configure", and the 2nd thing is it's common knowledge
> that that's how one
> runs configure.  You don't have the common knowledge
> yet because you're new at
> this.  That's OK.
> For the heck of it I tried to build this GNU netcat from the
> SourceForge
> package.  I used:
>     ./configure
>     make
> That's when I found out the code won't compile because
> Cygwin's struct
> in_pktinfo is missing a field that Linux apparently has:
> ipi_spec_dst. 
> Fortunately I could get around that by subverting the
> configure check for struct
> in_pktinfo.  I changed line 8865 of configure,
> inserting two leading slashes to
> comment out the line.  Then I ran ./configure
> again.  Then make.  That built a
> netcat.exe in the src subdirectory.
> Does it have the options you need?  I don't know. 
> But now you know how to build
> it yourself to find out.
> HTH,
> ..mark

Thanks..  The instructions in INSTALL seem standard, e.g. they don't mention netcat. it's just a standard set of instructions for doing ./configure and make. They mention ./configure.. 

  What I meant was really there was no configure! What had happened was I downloaded some version without the "configure" file..   I went to the CVS repository   and clicked download GNU tarball and got netcat-netcat.tar.gz
I should've clicked
and got netcat-0.7.1.tar.gz

But since you mention "configure" existed, I then found the right one.  

I amended the configure file as you mention.

I still get an error in the make.. and then no netcat.exe in the src subdirectory

make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/Steve/netcat/lib'
make[2]: Leaving directory `/home/Steve/netcat/lib'
Making all in src
make[2]: Entering directory `/home/Steve/netcat/src'
gcc -DLOCALEDIR=\"\/usr/local/share/locale\" -DHAVE_CONFIG_H -I. -I. -I..      -
g -O2 -Wall -c `test -f 'udphelper.c' || echo './'`udphelper.c
gcc  -g -O2 -Wall   -o netcat.exe  core.o flagset.o misc.o  netcat.o network.o t
elnet.o  udphelper.o -lintl
core.o: In function `core_listen':
/home/Steve/netcat/src/core.c:225: undefined reference to `_udphelper_ancillary_
collect2: ld returned 1 exit status
Makefile:231: recipe for target `netcat.exe' failed
make[2]: *** [netcat.exe] Error 1
make[2]: Leaving directory `/home/Steve/netcat/src'
Makefile:220: recipe for target `all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Steve/netcat'
Makefile:175: recipe for target `all' failed
make: *** [all] Error 2

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list