Portmap RPC registration fails

Ken ken@sixtus.plus.com
Sun May 6 22:22:00 GMT 2012

Portmap RPC registration fails

I have sunrpc 4.0-4 and libtirpc-devel 0.2.1-1. I'm using Windows 7 SP1.

I compiled and linked the following outline code against tirpc:

  #define PROG 0x1fffffffL
  #define VERS 0x2L

  struct netconfig *nconf = getnetconfigent("tcp");

  static void dispatch_func(struct svc_req *request, SVCXPRT *xprt)

  svc_handle = svc_tli_create(RPC_ANYFD, nconf, NULL, 0, 0);

  if (svc_reg(svc_handle, PROG, VERS, dispatch_func, nconf) == 0)

I ran portmap then tried to register with it using the above code. However,
I get back a zero response from svc_reg indicating failure to register.

This isn't due to my firewall as turning this off doesn't help. I've also
tried disabling all my network adapters in turn. There's nothing in the
portmap log. The CygWin NFS server works OK with the portmapper. No other
portmapper is running. rpcinfo gives:

  100000    2   tcp    111
  100000    2   udp    111

Any ideas?

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list