"emacs -nw" hangs in a terminal

Filipp Gunbin fgunbin@fastmail.fm
Tue May 15 12:27:00 GMT 2012

Sorry, the message disappeared for some reason. Here it is.


Ken Brown writes:

> On 5/15/2012 6:57 AM, Filipp Gunbin wrote:
>> I tried emacs-24, but with no luck: after hitting `C-x C-f C-g' emacs
>> almost always dumps core.  I had to revert to emacs-23 for now (using
>> the workaround with emacs-nox, thanks for it!).
>> Sorry for the poor report, probably I could provide more details if
>> needed.
> Please do provide details, including the cygcheck output requested at
>   http://cygwin.com/problems.html
> Give a complete recipe for reproducing the problem, preferably
> starting with `emacs -Q'.
> Thanks.
> Ken

Attached the output from cygcheck. For some reason it dumped core too:

$ cygcheck -s -v -r > /tmp/cygcheck.out
Segmentation fault

Other programs seem to work normally (though I haven't tried many).

The steps to reproduce the problem with emacs-24 are:

1. start emacs: emacs -nw -Q
2. C-x C-f C-g
Here emacs either dumps core or hangs.

I didn't have any problems with other Cygwin programs in the last


Filipp Gunbin

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list