Making Unix like paths work when using java program from Cygwin

Fri May 18 08:56:00 GMT 2012

I am working in a team where everyone else has a Linux/Mac OS X workstation,
but I have a windows workstation. Our project uses a shell script and a java
program to automate some deployment/setup etc, which needs to create some
directories of the sort /ABC/XYZ.
Obviously such paths are not valid in Windows.

I was hoping if I executed these scripts from within a Cygwin terminal, the
problem might be solved (with /ABC/XYZ mapping to C:\cygwin\ABC\XYZ

While the issue gets solved for the shell scripts, it does not for the java
program. I realize this happens because the Cygwin executes the very same
java.exe program which is installed on Windows (even though I selected
'java' related packages for installation while installing Cygwin). Is there
a way to get the equivalent of the "native" javac and java programs one
would find on a typical Linux workstation.

If not, can I accomplish what I want using the gcc java compiler gjc?

(Note: I am a relative newbie to Linux, and a complete newbie to Cygwin...
my apologies :)
View this message in context:
Sent from the Cygwin list mailing list archive at

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list