1.7.15-1: pthread_cancel and pthread_kill not working as expected

Corinna Vinschen corinna-cygwin@cygwin.com
Wed May 23 20:26:00 GMT 2012

On May 23 19:54, Corinna Vinschen wrote:
> On May 23 10:42, David Rothenberger wrote:
> > On 5/23/2012 10:18 AM, Corinna Vinschen wrote:
> > > Ok, for the time being I checked in my workaround.  Please test the
> > > today's developer snapshot.
> > 
> > I tried installing this snapshot and found most things hung.
> > Specifically, I ran ash in a Windows cmd window, then tried
> > 
> >   /bin/echo foo
> > 
> > I tried mintty too but bash hangs before I get a prompt.
> Big fat sigh.  This all worked fine while debugging.  Just that the
> snapshot is built with optimization and my debugging version is not.
> Ok, back to the drawing board.

I think I found the problem.  I've uploaded a new snapshot.  Please give
it a try.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list