1.7.15-1: pthread_cancel and pthread_kill not working as expected

David Rothenberger daveroth@acm.org
Thu May 24 05:52:00 GMT 2012

On 5/23/2012 1:10 PM, Corinna Vinschen wrote:
> On May 23 19:54, Corinna Vinschen wrote:
>> On May 23 10:42, David Rothenberger wrote:
>>> On 5/23/2012 10:18 AM, Corinna Vinschen wrote:
>>>> Ok, for the time being I checked in my workaround.  Please test the
>>>> today's developer snapshot.
>>> I tried installing this snapshot and found most things hung.
>>> Specifically, I ran ash in a Windows cmd window, then tried
>>>   /bin/echo foo
>>> I tried mintty too but bash hangs before I get a prompt.
>> Big fat sigh.  This all worked fine while debugging.  Just that the
>> snapshot is built with optimization and my debugging version is not.
>> Ok, back to the drawing board.
> I think I found the problem.  I've uploaded a new snapshot.  Please give
> it a try.

Works for me now. I also ran the libapr1 tests in case this touched any
of the various mutex stuff and they all passed, too.

David Rothenberger  ----  daveroth@acm.org

bug, n:
        A son of a glitch.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list