Mintty Log Off problem (now 1.7.16s)

Ryan Johnson
Tue May 29 13:43:00 GMT 2012

On 28/05/2012 1:32 PM, Harry G McGavran Jr wrote:
> On 02/18/12 11:28, Harry G McGavran Jr wrote:
>> I've found a little more information -- this problem goes away
>> if I change my default shell to dash.  Seems tcsh is involved somehow.
>> It comes back when I change my default shell back to tcsh.
>> Going back to tcsh 6.18.00-2 does not help.
>> Given the deathly silence to my request below, I must be the only
>> one experiencing this, but it happens on both of my machines.
>>      Harry
>> On 02/15/12 10:43, Harry G McGavran Jr wrote:
>>> With Cygwin 1.7.10(0.259/5/3) upon logging off Windows XP SP3
>>> I get a pop-up window "End Program - C:\cygwin\bin\mintty.exe"
>>> with a "End Now" and "Cancel" button every time I log off
>>> Windows and I have somewhere in that Windows session run
>>> the Mintty shortcut which has "C:\cygwin\bin\mintty -u -"
>>> in it and my default shell is tcsh. This never happened
>>> with previous Cygwin releases. What's even more interesting
>>> is that in all cases I exit all my programs before logging
>>> off, including the mintty window. I've even tried hitting
>>> the "Cancel" button and then looking for a process named
>>> mintty or "Terminal" (since that's what mintty's description
>>> is and that is used by some process tools) with both Process Explorer
>>> and Task Manager, but I can find no such process -- and then
>>> when I try to log off again not having found such a process
>>> the pop-up comes back and I can't log off until I hit
>>> "End Now".
>>> Since I haven't seen any reports of this on this list, I must
>>> be about the only one this is happening to. Any clues as to
>>> what I can do to find out what Windows is actually failing to stop
>>> when I try to log off having run mintty beforehand?
> I'm puzzled why others aren't seeing this or aren't reporting it,
> but this problem seems to be back with 1.7.15 and I've now tried
> the latest snapshot (May 25) and it's back there too. It occurred
> with 1.7.10 and then got fixed, but now it seems to be back.
I routinely encounter mintty windows that don't close after I exit the 
login shell they run (even though they contain no visible child 
processes), but they can still be closed using the big red "X" in the 
corner... your problem sounds like something more sinister.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list