Cygwin 1.7.17 breaks unattended setup

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Wed Oct 24 22:34:00 GMT 2012


On 10/24/2012 9:16 AM, Stefan Rusek wrote:
> I have a script automates installing and setting up sshd using cygwin.
> It first downloads the latest setup.exe then runs the following:
>
>> setup.exe  -q -s ftp://mirror.cs.vt.edu/pub/cygwin/cygwin/ --no-verify -R c:\cygwin
>> c:\cygwin\bin\bash --login -c "/bin/mkpasswd | sed 's/Administrator:unused:500:513/root:unused:0:544/g' | sed 's/:513:/:545:/' > /etc/passwd"
>> c:\cygwin\bin\bash --login -c "/bin/mkgroup -l > /etc/group"
>> setup.exe  -q -s ftp://mirror.cs.vt.edu/pub/cygwin/cygwin/ --no-verify -R c:\cygwin -P cygrunsrv
>> setup.exe  -q -s ftp://mirror.cs.vt.edu/pub/cygwin/cygwin/ --no-verify -R c:\cygwin -P openssh
>> c:\cygwin\bin\bash.exe --login -c "/bin/ssh-host-config -y --pwd ***"
>> sc.exe failure sshd reset=0 actions=restart/0/restart/0/restart/0
>> net start sshd
>
> This was working great last week, but on the 20th it stopped working.
>
> It fails on the line installing cygrunsrv, if I run setup.exe in
> interactive mode, I can install cygrunsrv just fine. Then the script
> fails to install openssh in the same way. Again a manual install works
> fine. I've tried different mirrors to no avail.
>
> The contents of /var/log/setup.log.full https://gist.github.com/3945977

Your problem is not with Cygwin 1.7.17.  That package wouldn't come into
play until the postinstall scripts.  Your log shows you don't get that
far.  And if it works interactively, then the problem is with 'setup.exe'
itself.  I can reproduce the problem but don't know why it's happening.
There hasn't been a new version of 'setup.exe' in quite a while so I can't
explain why you would just start seeing the problem within the last week.


--
Larry

_____________________________________________________________________

A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list