A problem with perl and cygpixman-1-0.dll

Reini Urban rurban@x-ray.at
Wed Oct 31 19:10:00 GMT 2012


On Wed, Oct 31, 2012 at 1:56 PM, Zdzislaw Meglicki  wrote:
>>> ./vendor_perl/5.14/i686-cygwin-threads-
>>> 64int/auto/Image/Magick/Magick.dll
>
>> the other two are probably coming from your build,
>> are the same or installed in different times ?
>
> I have by now overwritten my own installation with
> the vanilla Cygwin perl-Image-Magick and
> perl-Graphics-Magick.

Good.

> There should not be any non-Cygwin
> stuff there. They both use the above Magick.dll,
> don't they?

No, they are totally different. They just have the same basename, by accident.

> All three versions of Magick.dll are different. The other
> two, the ones that live in vendor_perl have dates July 26
> and April 28. I have not been doing anything with them
> at the time, so these must be some earlier versions
> installed by Cygwin itself. I am surprised perl reinstall,
> which I did recently, did not get rid of them.

If you are not using any perl site_lib dlls, rebaseall is enough.
If you are using perl site_lib dlls, you need to do perlrebase also.

In your case you did not have perl-Image-Magick installed, you installed it
seperately via CPAN into site_lib. This might create conflicts, if they are
from different versions.
-- 
Reini Urban
http://cpanel.net/   http://www.perl-compiler.org/

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list