Pavel Fedin
Thu Aug 1 13:09:00 GMT 2013


> The errors i obtain are as follows:
> /tmp/lcl/tmp/cygwin/cygwin-snapshot-20130731-1/winsup/c++wrap: line 2:
> use: command not found
> /tmp/lcl/tmp/cygwin/cygwin-snapshot-20130731-1/winsup/c++wrap: line 3:
> use: command not found

 Yesterday i have successfully compiled CVS version of cygwin.

 Your symptoms looks like another problem, which i attempted to address by another patch, posted alongside this one (no-dos-paths-on-cygwin). The problem is by default make's configure thinks that it should use DOS-style paths by default. Since Cygwin by itself is a POSIX environment, which uses POSIX paths, this screws up badly in functions which deal with absolute paths. You can find the detailed description in this message: . Perhaps you (and someone else ? Corinna ? ) can join the discussion and help me to convince GNU people that these modifications are good and safe.
 You can either apply this patch before running configure (and don't forget to recreate it with autoconf, of course), or bypass the check using config.cache trick:
--- cut ---
echo "ac_cv_dos_paths=no" > config.cache
./configure --cache-file=config.cache
--- cut ---

 Actually i already tried to post this patch here some time ago, here is the thread: . For some reason those days back my attempts to send a patch were rejected from both addresses (work and home), so this ended up in a private discussion with Reini and Cristopher (IIRC). Someone of them told me that Cygwin's policy regarding make is to send all modifications upstream, so this time i tried directly on GNU mailing list. Of course i won't subject if the patch is accepted as part of Cygwin package. I'm just not very fond of rebuilding tools manually after every update.

Kind regards,
Pavel Fedin
Expert Engineer
Samsung Electronics Research center Russia

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list