bash ignoring set -f on windows

Craig Ryan cryan.dublin@gmail.com
Mon Aug 12 16:00:00 GMT 2013


> I think putting the blame on bash is premature.  Try replacing the call to
> java with a script of your own to see what arguments it get called with,

How so? This works on un*x platforms so what am I missing?
The script IS my own, if you execute the script as suggested what
results did you get with cygwin/windows?

> then read this:
>
> http://www.oracle.com/technetwork/java/javase/7u4-relnotes-1575007.html

I read this, I'm not sure what it provides as a solution? Apart from
the fact that I dont require java 7, what is the expected cygwin bash
glob behaviour?
I ran my script with \"$ARGV\" as suggested and the output per my java
app is 'WRONG! NO ARGS AT ALL - should be '*'". If you can illustrate
how to make this work I'd like to see it because I've tried a lot of
variations with cygwin without sucess and so far I can only conclude
that 'set -f' is being ignored. Thanks for responding Achim but please
do try the code I provided and see what results you get.

Just a minor correction to my post, on Mac I said "with ‘set –f’
active expansion does occur as expected", instead I meant 'with set -f
removed from the script expansion does occur as expected'.

cheers,
craig.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list