svn 1.7.10-1 on x86_64 does not work

David Rothenberger daveroth@acm.org
Wed Aug 28 18:19:00 GMT 2013


Corinna Vinschen wrote:
> On Aug 28 09:05, Robert Klemme wrote:
>> On Tue, Aug 27, 2013 at 6:14 PM, David Rothenberger
>> <daveroth@acm.org> wrote:
>>> On 8/27/2013 9:04 AM, Robert Klemme wrote:
>>>> $ svn --version /usr/bin/svn.exe: error while loading shared
>>>> libraries: ?: cannot open shared object file: No such file or
>>>> directory
>>> 
>>> Check that you have libneon27 installed. That's missing from
>>> the dependencies. If that doesn't work, try "cygcheck
>>> /usr/bin/svn", which might tell you what else is missing.
>> 
>> $ fgrep -i libneon /etc/setup/installed.db $ cygcheck $(type -p
>> svn) >/dev/null cygcheck: track_down: could not find
>> cygneon-27.dll
>> 
>> Bingo!  I installed it and now it works.
> 
> So libneon27 should be added to subversion's setup.hint requires?

Sigh. I guess. It's only required by 1.7, not by the latest 1.8, so
it's not caught by cygport automatically. (I know, I know, I should
review the auto-generated requires.)

-- 
David Rothenberger  ----  daveroth@acm.org

This restaurant was advertising breakfast any time. So I ordered
french toast in the renaissance.
                -- Steven Wright, comedian

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list