previously reported test case does not work in Cygwin 1.7.18

Andreas Steenpaß steenpass@mathematik.uni-kl.de
Fri Aug 30 14:40:00 GMT 2013


I would like to bring the issue described below up again. I have just
tested this with Cygwin 1.7.24, and it shows the same behaviour as
before, so it seems that this bug still persists.

My system is:
$ uname -a
CYGWIN_NT-6.1-WOW64 zoppo 1.7.24(0.269/5/3) 2013-08-15 11:55 i686 Cygwin

Best regards,
Andreas


Le 25/04/2013 12:06, Andreas Steenpaß a écrit :
> I have tried to run the following test case with the newest release:
>
> http://cygwin.com/ml/cygwin/2012-12/msg00076.html
>
> It used to work after it was fixed, but now it seems to be broken again.
> Actually, it is even worse than before because now, not even thread 1
> catches SIGUSR2:
>
> $ uname -a
> CYGWIN_NT-6.1-WOW64 zoppo 1.7.18(0.263/5/3) 2013-04-19 10:39 i686 Cygwin
> $ ./testcase1
> pid: 3628
> thread 1 waiting for SIGUSR1
>
> // from another console, send SIGUSR2, then SIGUSR1 (in this order!)
> $ kill -SIGUSR2 3628
> $ kill -SIGUSR1 3628
>
> // The program catches only SIGUSR1, but not SIGUSR2:
> thread 1 received SIGUSR1
> thread 1 waiting for SIGUSR2
>
> Best regards,
> Andreas
>
>
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>
>
>


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list