cannot execute binary file

Larry Hall (Cygwin)
Tue Dec 17 02:39:00 GMT 2013

On 12/16/2013 7:32 PM, Gerry Reno wrote:
> On 12/16/2013 07:27 PM, Max Polk wrote:
>> On 12/16/2013 5:55 PM, Gerry Reno wrote:
>>>       /usr/bin/ls: /usr/bin/ls: cannot execute binary file
>>>       /bin/bash: Exit 126
>>> This is the error that greets me when I try to execute a command in cygwin from a Windows Command Prompt like so:
>>>       C:\cygwin\bin\mintty.exe -h always /bin/bash -l ls
>>> This was after installing a new version of Cygwin today.  So I wiped it and installed it again and got the same error
>>> again.
>>> This used to work because I've called my own scripts this way before.  Is there some new way of doing this?
>> If you provide a "minus c" option, it will work:
>> C:\cygwin\bin\mintty.exe -h always -e /bin/bash -l -c ls
> I just tried it with -c and all it gives you is a totally blank window.
> Tried a bunch of other commands using the -c and same thing.  Just a blank window.

In that case, there's something in your installation that isn't quite right.
The above suggestion resolves the issue you described just fine for me.  If
you're still experiencing the problem when you use the '-c' flag and need to
consult with the list further on this issue, I recommend following the
problem reporting guidelines found at the link below with your next message:

> Problem reports:



A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list