Fwd: Fwd: infocmp.exe opens in a new windows-cmd window and hangs

Irfan Adilovic irfanadilovic@gmail.com
Mon Dec 23 20:52:00 GMT 2013


It was the BLODA -- fixed by disabling Avast, thanks a lot...

-- Irfan

On Mon, Dec 23, 2013 at 9:25 PM, Christopher Faylor wrote:
> On Mon, Dec 23, 2013 at 08:09:46PM +0100, Irfan Adilovic wrote:
>>On Mon, Dec 23, 2013 at 5:06 PM, Larry Hall (Cygwin) wrote:
>>> On 12/22/2013 9:09 PM, Irfan Adilovic wrote:
>>>>
>>>> On my 64-bit Cygwin installation, when I start `infocmp.exe` from
>>>> within mintty, it opens up a new cmd-window (not mintty!), shows
>>>> options and immediately closes. However, the infocmp process hangs in
>>>> a way that defies killing -- it cannot be killed even from the windows
>>>> task manager (first attempt at killing has no effect, later attempts
>>>> return "Access is denied"). Same thing for its parent process, sh.exe.
>>>> So far, I haven't found a way of killing these two processes short of
>>>> restarting the system.
>>>>
>>>> A workaround is to either uninstall ncurses or to move away
>>>> infocmp.exe -- with luck, stuff will work (for example, `perl -de0`
>>>> hangs because of infocmp, but works flawlessly with infocmp moved
>>>> away).
>>>>
>>>> Now, has anyone else observed this, or am I the only one? I've tried
>>>> reinstalling ncurses without effect, any other suggestions?
>>>>
>>>> I'm running 64-bit Cygwin under Windows 8.
>>>
>>>
>>> No problem for me on Windows 7, 32-bit.  If you're still having trouble,
>>> please read and follow the problem reporting guidelines found at the link
>>> below with any follow-up mail to the list.  That will help others on the
>>> list do some basic evaluation of your issue.
>>>
>>>> Problem reports:       http://cygwin.com/problems.html
>>
>>I'm running cygwin 64-bit, version 1.7.27(0.271/5/3), under Windows 8
>>Professional. When I run infocmp.exe (without arguments) from the
>>ncurses package, from within a mintty terminal, it opens up a new
>>cmd.exe window, prints whatever it is supposed to print when called
>>without arguments and then exits, closing the cmd.exe window. Invoking
>>with '>/dev/null 2>/dev/null' behaves exactly the same as without.
>>
>>I was able to capture the cmd.exe window (which is closed
>>instantaneously) with a screen recording software and then extract the
>>frame, see here: http://s21.postimg.org/jwz9s8dlz/infocmp_normal.jpg .
>>I have also observed a stacktrace in that cmd.exe window once, but
>>couldn't figure out what causes it (a different executable filename is
>>not the cause, and it happened only once out of about 6 times I
>>recorded the screen):
>>http://s18.postimg.org/a7pzrbuih/infocmp_stacktrace.jpg
>>
>>Now, even after the cmd.exe window is closed, infocmp.exe remains
>>running in the mintty terminal and cannot be killed. After pressing
>>Ctrl-C, the following output is always shown after a variable amount
>>of time (in a couple of tests, I got values between 20 and 50
>>seconds):
>>
>>irfan@irfy:/usr/bin$ ./infocmp.exe
>>      1 [sig] -bash 16792 get_proc_lock: Couldn't acquire
>>sync_proc_subproc for(5,1), last 7, Win32 error 0
>>    497 [sig] -bash 16792 proc_subproc: couldn't get proc lock. what 5, val 1
>>
>>The first number on the second line of output corresponds to the
>>amount of time waited in 1/10ths of a second.
>>
>>Looking at the task manager reveals an sh.exe parent and an
>>infocmp.exe child, neither of which can be killed: "Access is denied".
>>I have to reboot to get rid of them.
>>
>>I stumbled across this problem by trying to run the perl debugger --
>>`perl -de0` -- which hangs as just described. Uninstalling the ncurses
>>package makes the perl debugger work -- as does moving away (renaming)
>>just the infocmp executable. Reinstalling the ncurses package does not
>>resolve the problem.
>>
>>I've attached my cygcheck.out (removed a couple of env-vars -- they do
>>not influence PATH-like variables anyway). You will notice that
>>cygcheck says that infocmp.exe is missing -- that's because I had it
>>moved away (renamed it) for `perl -de0` to work at the time of running
>>cygcheck.
>>
>>I don't think it should make a difference, but someone on
>>stackoverflow thought that mintty terminal options could cause the
>>problem -- I have changed some colors and fonts, changed mouse
>>behavior to mimic PuTTY, but I left the terminal type at 'xterm' and
>>answerback empty.
>>
>>I have also tried to start the infocmp.exe directly from the common
>>cmd.exe shell -- it always ended up in a stack trace. (This could be
>>normal I guess)
>
> I just tried running infocmp from both mintty and cmd on Windows 8.1
> 64-bit.  The behavior is as expected.  No terminal window, no stack
> trace.  I'm surprised that "perl -de 0" causes infocmp to be run but
> that works fine too.
>
> If you haven't upgraded to Windows 8.1, maybe that will fix the problem.
> Otherwise, I suspect BLODA.
>
> http://cygwin.com/acronyms/#BLODA
>
> cgf
>
> cgf
>
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list