Fwd: getcwd in Make's Test Scripts Causes Errors

marco atzeri marco.atzeri@gmail.com
Tue Jul 9 05:50:00 GMT 2013

Il 7/9/2013 7:13 AM, GJ ha scritto:
> Hello,
> I'm trying to build Make-3.82 in Cygwin64 1.7.21-6 on Windows 8 x64.
> It appears to build just fine, but I can't run the tests.  I've tried
> running it with "make check", "perl run_make_tests.pl", and the latter
> in Window's own CMD.exe.  When a test fails, it produces the error
> "shell-init: error retrieving current directory: getcwd: cannot access
> parent directories: No error".
> Attached is a cygheck.out, the script I ran to try to build and test
> Make in "conf-make-inst.sh", (so it's easy to see how to reproduce the
> problem) and the output of the script in "build log.txt".  "build
> log.txt" is just the output of "conf-make-inst.sh".  It contains the
> output from the configure, make, and make check commands.
> I can't seem to find much information on this, or I don't have the
> expertise to understand the information out there on errors with
> getcwd and Cygwin.  Did I include all the information needed to be
> helpful?
> Thanks for your consideration.

why building something already available ?

$ make --version
GNU Make 3.82.90

have you checked the cygwin source package of make ?
Following the same road is likely easier.


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list