emacs problem

Ken Brown kbrown@cornell.edu
Wed Jul 10 20:55:00 GMT 2013

On 7/10/2013 3:07 PM, J. David Boyd wrote:
> Ken Brown <kbrown@cornell.edu> writes:
>> On 7/10/2013 2:07 PM, J. David Boyd wrote:
>>> I'm starting to see this error quite a bit in the terminal window I started
>>> emacs from:
>>> 0 [main] emacs-X11 19400 C:\tools\cygwin\bin\emacs-X11.exe: *** fatal error in
>>> forked process - failed to create new win32 semaphore, Win32 error 87
>> Have you tried rebaseall
>> (http://cygwin.com/faq.html#faq.using.fixing-fork-failures)?  This
>> isn't the typical error message you see from rebase problems, but it
>> can't hurt to try.  If that doesn't help, maybe you could test the
>> build I mentioned at
>>    http://cygwin.com/ml/cygwin/2013-07/msg00062.html
>> Ken
> Yes, the first thing I tried was rebaseall, but that also gives (in my
> history) the message about not being able to fork a new process.

Are you saying you get a fork error when you run rebaseall?  If so, I 
think you need to fix that before you can hope to avoid fork errors in 
emacs.  Have you looked for BLODA?  Other than that, I don't know what 
to suggest (except that you should send cygcheck output when you write 


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list