mingw/math.h not found while compiling R packages

Enrico Ferrero enricoferrero86@gmail.com
Thu Jul 11 17:20:00 GMT 2013


Hi Larry,

Thank you for your reply and advice.

> If you are using the R from Cygwin Ports, it must be an old package since
> R is no longer offered there.  I suggest you install the R package from the
> Cygwin distribution instead and retry.  Since this list supports the Cygwin
> distribution only, this would put your issue firmly on-topic for this list
> if you can still reproduce it.  For Cygwin Ports packages, they are
> supported through the Ports site:
> <http://sourceware.org/cygwinports/>
> If you have a package from that site and have questions, problems, or
> comments, it's best to consult the mailing list there.
> --
> Larry

I got confused in my first email for some reason, but I'm definitely
using R (version 2.15.1) from the Cygwin distribution, not the ports.
I just made a clean R installation just to make sure and I still get
the same error message:

>In file included from IntervalTree.c:3:0:
>common.h:59:24: fatal error: mingw/math.h: No such file or directory
>compilation terminated.
>/usr/lib/R/etc/Makeconf:121: recipe for target `IntervalTree.o' failed
>make: *** [IntervalTree.o] Error 1
>ERROR: compilation failed for package ‘IRanges’
>* removing ‘/usr/lib/R/site-library/IRanges’

I've read there are some other problems with MinGW these days, maybe
this one is related?
In any case, is there anything I can do to try to solve the issue?
Bioconductor is vital to me and using R from within Windows is causing
me a lot of headaches.

Thanks!
Best,

Enrico

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list