1.7.22: CTRL+C on mingw applications

Roland Schwingel roland.schwingel@onevision.de
Tue Jul 23 12:35:00 GMT 2013


Due to some odd hangs in some past versions of cywin1.dll (1.7.18 - 
1.7.21) I was still using 1.7.17. Now I gave 1.7.22 a new try. The 
blocks seem to be resolved but well it appears that cygwin can now no 
longer break running standard windows/mingw tools.

I am using 1.7.22 (32bit) with mintty on windows 7 Ultimate 64bit. All 
cygwin packages are up to date. My $CYGWIN is set to "nodosfilewarning".

Pressing CTRL+C is simply ignored for mingw apps while it works for 
cygwin executables. When I run cywin from within a windows dos box my 
exes stop to work but the console than hangs until execution of the 
started executable has finished. stdout of the executable seem to be 
redirected to /dev/null after pressing CTRL+C in console window.

I today tried all officially released cygwin1.dlls from 1.7.17 to 1.7.22 
but all versions starting with 1.7.18 do show this problem.

Have I missed something in the time between 1.7.17 and now or is this a 
"new" bug (I could only loosely follow the mailing list in the past months)?

Thanks for your help,


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list