Win32 error in C program using openmp and fork()

Ken Brown
Tue Jul 23 13:15:00 GMT 2013

On 7/23/2013 8:28 AM, Daniel Brown wrote:
> I've wiped my old version of Cygwin and installed it fresh on my computer
> and 1.7.21 doesn't work for me, either 32 or 64 bit. I have tried a Win
> 7 x86
> virtual machine and it worked, on a Win 8 x86 virtual machine though I see
> the same error. Therefore I guess it is a Windows 8 issue

No, I can reproduce it consistently on my Windows 7 system, running 
1.7.22, on both 32-bit and 64-bit.  It also just happened to me while 
running emacs.  This is not reproducible, but it was previously reported 
by another user:

On 64-bit, the output is

$ ./openmp-test.exe
I'm an openmp thread...
I'm an openmp thread...
I'm an openmp thread...
I'm an openmp thread...
Parent fork
       0 [main] openmp-test 6640 
C:\cygwin64\home\kbrown\openmp-test.exe: *** fatal error in forked 
process - failed to create new win32 semaphore, currentvalue 4294967294, 
Win32 error 87


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list