Upgrade Challenges, ssh login failure after update

Stefan Lisowski s.lisowski@isti.com
Tue Jul 23 18:14:00 GMT 2013

I just updated Cygwin to the latest version from one that had been 
installed in maybe 2009... old.

During the update process there was a note to go to cygwin.com to see 
what had changed in the new version that might affect me, but in the 
"upgrade" or the "faq" area I could find nothing warning me about 
anything specific.

I was installing this on a box 2000 miles away where I tunnel remote 
desktop through ssh. Thank goodness I took down the firewall before I 
rebooted, because ssh no longer worked after a reboot, and I had to make 
a direct remote desktop connection to the machine before I got ssh up 
and running.

I'm sending this mail to warn other users trying to upgrade sshd... 
After the upgrade I got login failures even though sshd service was 
running. I Googled and Googled, but I couldn't find an answer; port was 
open, ssh was up, and ssh connections worked fine (even to the external 
IP) from the local cygwin ssh, but not from a remote ssh. Logging 
locally didn't help, ssh -vvv remotely didn't help. FINALLY I figured it 
out, it was that the USERNAMEs are now case sensitive!!! So 
"administrator" fails but "Administrator" succeeds. I read somewhere I 
can fix this now by going back and editing /etc/passwd, but I haven't 
tried that yet; right now I'm just happy to have my firewall back up and 
tunneling remote desktop through ssh again. (I did a ssh-host-config in 
the process of debugging but I don't think I needed to.)

Since I couldn't find this answer I'm sending it now to the list, 
hopefully the next person that runs into this will find it.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list