Cannot build debug/-Zi using VS 2010 SP1 via ssh with public key auth from local administrator account

Larry Hall (Cygwin)
Fri Jul 26 17:41:00 GMT 2013

On 7/26/2013 12:59 PM, J. P. Abelanet wrote:
>> Have you tried VS 2012?   Have you checked with MS about this?
> I  can't use VS 2012 for now, because none of the 4 Windows build machines I
> use are running Windows 7 or newer.  I suppose that if this drags out, that
> may become my only option.
> As far as checking with MS, I have not. My best guess, since all 4
machines received
> the same upgrade to VS 2010 SP1, was that something had changed in the way
> authentication was handled for the pdb database between VS 2008 and VS 2010 SP1
> (actually, the problem seemed to occur between VS 2010 and VS 2010 SP1, but that
> could be because the machine wasn't rebooted, etc)
> and that was incompatible with a change that occurred in CYGWIN somewhere
> between 1.7.5 and 1.7.20.

It's worth trying 1.7.22.

> I've since tried the following:
> - running ssh-host-config on (a) and rebooting, with no effect
> - completely removing CYGWIN and all traces of sshd
> ( and reinstalling on
> (a), with no effect

We discourage people from following Cygwin advice from ad-hoc sites.  In
this case, it provides a synopsis of how to do this and then points to a
link in the Cygwin FAQ from where the synopsis came.  Two things should
make anyone think twice about the information at this site:

   1. It points to the Cygwin FAQ as the source.
   2. The link to the Cygwin FAQ is broken.

This is a good indication that the information you're getting is second-hand 
and outdated.  Unfortunately, this is a common occurrence for
these sites proclaiming to have useful Cygwin information.  That's why we
discourage consulting them.

Currently, I don't see anything that egregious at this site so I think
you're OK for now.

> - completely removing VS 2010 and all related packages (I think), and
> trying to build using the untouched version of VS 2008 I had previously been
> using, and now building debug across CYGWIN/ssh/pub key with VS 2008 fails
> as well

Yeah, that of course assumes that the uninstall undid all that the install
did.  There's not a good way to verify that.  If you can narrow down the
time-frame (with the Cygwin Time Machine for example - Google it) when you
see the problem appear, that could help find a solution, assuming you're
still seeing the problem with 1.7.22.



A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list