Drag a file into emacs-w32 frame

Arthur Tu arthur.jim.tu@gmail.com
Mon Mar 4 16:25:00 GMT 2013


Today when i tried to drag a file whose name containing chinese 
characters into emacs, it failed to open.

Here is the brief review:

1. a file with a pure english file name to emacs-32 frame:

     open successfully.


2. a file with chinese characters in its name to emacs-32 frame:

      error message: "dnd-open-local-file: Can not read 
file:/cygdrive/c/Users/Arthur/Desktop/%20%20%20%20.txt".
     in fact, i tried several times with different name. the name was 
always decoded as a punch of "20%", even though different chinese 
characters were there.


3. the same file with chinese characters in its name to a emacs-nox 
frame(mintty):

     the file name was pasted into the buffer correctly. chinese 
characters were shown correctly. the file wasn't open. (This is what's 
expected to happen in terminal session.)


So my question was around the situation 2.
How did the emacs-w32 handle the dragged file?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list