Shouldn't gcc-4 depend on libmpfr4 ?

Achim Gratz Stromeko@NexGo.DE
Wed Mar 6 11:08:00 GMT 2013


Yaakov <yselkowitz <at> users.sourceforge.net> writes:
> AFAIK nothing used the BSD compat layer, it was disabled by default
> upstream, and Fedora has already updated to 5.1.  I think we can go
> ahead and do the same.

I've produced a 5.0.5 package anyway so that library will be at the latest
existing version just to be sure.  Now, the remaining problem is that updating
libmpc produces cygmpc-3.dll while gcc expects cygmpc-1.dll.  Should these be
linked (the ABI is AFAICT the same since the original cygmpc-1.dll was produced
by overriding the version number)?  After all, the trigger for the whole
exercise was to ensure that gcc doesn't pull in two different versions of
libmpfr via libmpc1...

Regards,
Achim.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list