PostgreSQL not working from start

Wynfield Henman wynfield@gmail.com
Fri Mar 22 07:18:00 GMT 2013


This is apparently a common problem.
I' m trying to install and get PostgreSQL up and running.

Yes, CYGWIN, the environment variable is set to "server" and file/dir
permissions are set for the user and have r/w permissions.

No matter if I use:

   initdb or  pg_ctl initdb -D $DBDIR -l $DB_ADMINLOG -o "-X $XLOGDIR
-U $DB_OWNER"

No database is initialized and the "Bad system call" messages in a
downward counting loop of shared_buffers appears on the screen. ending
with]
...creating configuration files ... ok
creating template1 database in /usr/local/share/db-datadir/base/1 ...
child process was terminated by signal 12: Bad system call
initdb: removing contents of data directory "/usr/local/share/db-datadir"
initdb: removing contents of transaction log directory
"/usr/local/share/db-logdir"

---

Then tried to use  pg_ctl start -D $DBDIR -l $DB_ADMINLOG
to get the server up and it failed (it did say it was looking in
$DBDIR for the config file which makes, sense as initdb failed and
deletes the contents it just made)

Still should be able to start the server, I think, so tried
$ pg_ctl start -
server starting

It says server starting.  But, no server was started or if it did it
did in its infancy, but no event logs show a service being started.

What are steps to use to get this database up and running. Would not
using pg_ctl or init_db and just starting a server and create by hand
a new database be easier an workable, or if now who to make them work
or fix them.?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list