Cygwin installer hangs while downloading files

Michael DePaulo
Mon Aug 18 12:56:00 GMT 2014

On Thu, Aug 7, 2014 at 8:32 AM, Michael DePaulo <> wrote:
> HI,
> I'm having a weird issue with the Cygwin installer. It occurs whether
> I am using it to update my 2 installations of Cygwin (both 32-bit and
> 64-bit), or to perform a new install. The issue is that the installer
> hangs while downloading files. In other words, the progress bar makes
> 0% more progress at some point during a download. I've let the
> installer sit for over several hours without it making any progress.
> Sometimes it's setup.bz2. Usually it's one of the packages. On
> average, it happens on the 3rd file or so. Sometimes the 1st,
> sometimes the 6th, etc. It usually occurs in the middle of a file
> download, but sometimes at the beginning of the file download (when
> progress is 0%.) The UI is still responsive when this happens; so I
> can quit the installer.
> My Setup:
> 1. Windows 8.1 64-bit with the latest updates.
> 2. Joined to a domain.
> I Tried the following, but the issue still occurs:
> 1. Disabling my antivirus (NOD32 Antivirus 7)
> 2. Using both 32-bit and 64-bit Cygwin installer
> 3. Using the download path C:\Users\mike.DEPAULO\Downloads\cygtemp
> instead of the path on the U: network drive with spaces in it.
> 4. Selecting different mirrors.
> I also tried using another computer (Same OS, joined to the same
> domain, but different AV) and the issue did NOT occur.
> My workaround right now is just repeatedly run "setup.exe -q" and
> quitting the install whenever it does hang, until the entire download
> completes successfully. Once the entire download does complete, the
> packages install without any issue.
> -Mike

The issue seems to be happening less frequently now. Today I
downloaded about 60 packages and it only happened once.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list