rsyncd broken

Corinna Vinschen
Thu Aug 28 10:06:00 GMT 2014

On Aug 28 10:22, Frank Fesevur wrote:
> 2014-08-25 9:46 GMT+02:00 Frank Fesevur:
> > 2014-08-22 14:42 GMT+02:00 Frank Fesevur:
> >> I will try a self build vanilla rsync.exe 3.1.1 this weekend or early
> >> next week and see how that works.
> >
> > I have tried my own build 3.1.1 last night and it fails with the same
> > errors. I will investigate this.
> Made a bit of progress. When I comment out the lines uid = 0 and gid =
> 0 from my /etc/rsyncd.conf v3.1.1. seems to work again, although I
> haven't tried on our production server yet. I rather wait with that
> until the weekend when there is not much to backup. I have not found
> out why this behavior has changed since v3.0.9.
> Another thing that surprises me is that the setuid() fails with an
> errno 5, which is EIO. That error is not mentioned on this man page
> What do you think? Is this setuid()
> error a cygwin specific problem or should I ask upstream?

That's probably a translation from Windows status or error code to POSIX
error code.  The setuid call is littered with debug output statements,
so a strace could help to understand where it comes from.  Basically
it's probably still rather an issue of missing caller permissions.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list