Latex font problem (attn: Yaakov)

Ken Brown kbrown@cornell.edu
Mon Nov 10 02:32:00 GMT 2014


On 11/8/2014 5:20 PM, phil rosenberg wrote:
> Hi
> I have discovered what I think is a tex/latex font problem. I am a developer for Plplot and we use docbook for building our documentation. I have been trying to get this to build correctly on Cygwin. The documentation uses the FreeFont fonts and these seem to be installed by the texlive-collection-fontsextra package. However, the documentation still would not build. After some more checking and looking into how fonts work on Linux and Cygwin I found that I needed to make the fonts available to fontconfig by adding the directory /usr/share/texmf-dist/fonts/ to a /etc/fonts/local.config file (along with the xml header copied from /etc/fonts/fonts.config).
>
> Basically my question is, should the fonts in this folder be made available to fontconfig during install? There are a number of ways to do this it seems - probably adding a config file somewhere and then adding a symlink to it in /etc/fonts/conf.d seems most sensible. Alternatively are these fonts not made available to fontconfig by design?

This is discussed in the texlive release announcement

   https://cygwin.com/ml/cygwin-announce/2014-07/msg00000.html

under the heading "Fontconfig".  See also

   https://cygwin.com/ml/cygwin-xfree/2014-05/msg00020.html

Yaakov, could we get a fontconfig update that fixes this?

Thanks.

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list