gnutls-3.2.20 doesn't compile anymore, probably conficting with installed libopts-devel

Dr. Volker Zell
Wed Nov 12 20:40:00 GMT 2014

>>>>> Yaakov Selkowitz writes:

    > On 2014-11-12 02:50, Dr. Volker Zell wrote:
    >>>>>>> Yaakov Selkowitz writes:
    >> > On 2014-11-11 14:44, Dr. Volker Zell wrote:
    >> >> Older gnutls versions compiled fine with cygwin. Latest versions come
    >> >> with their own libopts source tree, which is newer than the latest
    >> >> cygwin version. I get the following error when trying to compile gnutls-3.2.20
    >> > I cannot reproduce this.  Do you have both autogen and libopts-devel installed?
    >> > Also, are you using the autogen VPATH patch:
    >> >
    >> >> Can we get a newer autogen package ?
    >> > I can do that, but that's not the problem here.
    >> You're right...I just installed it but the same error. What cygport file
    >> are you using ?


I now tried the compilation with your cygport and your two patches but I
still get the same error. I also updated to the latest autogen package
you just provided. Do you mind sending me your compilation log files...I
would like to diff them with mine...

I haven't done any cygwin stuff since more than a year, and I recently
updated my cygwin installation to ALL the current packages (both
32/64bit) , but something seems strange here. I want to sort this out
before updating my packages to their latest upstream versions. By the
way the current gnutls compilation has been done on a 32bit
installation, so please send me the corresponding log files.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list