python binary retrieved via (cygwin) git clone does not execute - error 127

Rick Springob
Wed Jun 24 14:46:00 GMT 2015

I cloned a repository using the git that comes with 64-bit cygwin. 
Executing python.exe in the repository results in an immediate return 
and an exit code of 127.

The python executable was built in 32-bit cygwin. The executable works fine
is 32-bit cygwin and 64-bit cygwin shells as long as the repository was
cloned with the git I was using before, msysgit. 

I have had no problem with python in the same repository on the Ubuntu and 
Mac OS platforms. The problem has only been seen with the git 
that ships with 64-bit cygwin.

64-bit cygwin
 - cygwin version 1.7.33
 - git version 2.1.1

32-bit cygwin
 - cygwin version 1.7.18
 - git version 1.8.1.msysgit.1

I have tried the git config core.filemode option with true and false values. 
This did not help.

git ls-tree shows the same file mode and checksum in both repositories,:
100644 blob abc25ddb6ed66d1bfe3f58de77b3fd3437b8e21f    python.exe

As per a post on the web, I tried to fix this using:
git update-index --chmod=+x python.exe
git commit ...

While that does change the file mode, python still exits with 127:
100755 blob abc25ddb6ed66d1bfe3f58de77b3fd3437b8e21f    python.exe

Python is in the path:
$ which python

Any idea what the cygwin provided git is doing differently than other git


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list