cksum giving inconsistent results on network drive

Erik Soderquist ErikSoderquist@gmail.com
Tue Mar 22 19:29:00 GMT 2016


On Tue, Mar 22, 2016 at 2:45 PM, Nellis, Kenneth wrote:
> Indeed, it is not cksum, but (almost) any Windows process that
> reads data mounted on my QNX4 Samba drive, including Cygwin's
> "cp", FileZilla, and Perl's File::Copy package. However, I have
> not got the DOS "COPY" command to deliver corrupted data, so I
> suspect it must be doing something special. So, with FileZilla's
> and others' failures, I've vindicated Cygwin, as it seems to be
> some problem between QNX4 Samba and Win7.
>
> Thanx to all who responded.
>
This feels like "from ancient times"... I remember the DOS 'copy'
command having a verify option that would effectively reread the data
to confirm it was written correct (and I think repeatedly rewrite the
data until it did read back correctly), and debate about making that
the default... I think there may have also been an environment
variable that could be set to override whichever was the default;
perhaps this is why 'copy' works were others see the underlying flaw?

I'd look at upgrading the QNX4 host if possible, even if it means side
loading something else onto it.  (I'm not familiar with "QNX4", but it
seems to be the root of the problem).

-- Erik

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list