Packages not found by setup 2.873

Warren Young wyml@etr-usa.com
Wed Mar 30 17:29:00 GMT 2016


On Mar 30, 2016, at 12:27 AM, EMMANUELLE FOURNIER <emmanuelle.fournier@partnre.com> wrote:
> 
> - packages are in tar.xz, I've made them in tar.bz2 

Why?  You’re using Cygwin’s own installer underneath NSIS, and that program has XZ decompression built in.  Why use a less efficient compression method?

> - setup.ini has been modify too 

How, exactly?  Can you provide a description of the change, a script you use to make the change, or a diff of the change?

> there are multiples errors : 
> 
> - no packages installed… 

How is that “multiple errors”?  Are you counting each package not installed as a separate error, or are you not telling us all of the symptoms?

> - the command is (in NSIS file) ExecWait '$INSTDIR\setup.exe -R c:\cygwin -L -l $INSTDIR\cygwin-setup -C base -P openssh,tcpwrapper,rsync,ping,vim,cron,shutdown,zip,unzip,wget,time -q’ 

I tried much that same command here, and it works.

Here are several things for you to look at:

1. What exactly is the content of $INSTDIR?  If it includes a network drive letter, it won’t work because setup.exe elevates itself to Admin via UAC, and Admin won’t have the same drive letters mapped.  To use a network drive with setup.exe, you generally have to use UNC paths.

2. Have you tried it with -D instead?  If that works, then your local installation cache probably isn’t complete.  Pack the downloaded tree up again and try -L against that new tree.

3. What does /var/log/setup.log say?  The file is rarely replaced, so you’ll have to scroll down to the last installation at the end of the file.  You might want to move the old one out of the way while debugging, so you only have fresh logs to study.

4. Is “-C base” actually required?  Even in unattended installer mode, Base should always be installed.
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list