Errors using configure when building packages

Linda Walsh
Mon Oct 17 19:44:00 GMT 2016

Sinkler, Wharton wrote:
> I've got a new Cygwin installation on Win7, which has issues with configure, the first step of building packages from source (I've seen this with ImageMagick, libtiff and others so it's not specific to the package I'm installing).  
> It seems to sporadically be unable to remove a file 'conftest.exe' which is compiled in the tests within configure.  This shows up during configure as:
> rm: cannot remove 'conftest.exe': Device or resource busy
> The configure will then fail completely when this causes a critical test to fail.  
> I suspect that this might have something to do with slowness to release an in-use file (the conftest.exe) in the Win7 operating system.  I've searched the archives and don't see this exact issue showing up in previous posts.  Have others experienced this problem?  Is there a fix which will allow me to complete building these packages? 
	I ran into a similar problem on linux - but was unable to
describe it to the point where others could reproduce it -- so I 
manually worked around it in each case where it happened, until some
SW-update to the autoconf-stuff made it go away.  It also happened in 
multiple packages, so wasn't specific to any one -- but it also 
happened on *linux*.

The problem is that somehow the information for "conftest.exe" will
be *in* the directory "conftest.exe" with some temporary name.  It's 
really a weird one -- but it happened with different files (where
the actual file was in a directory that had the name of the file, and
the actual file being in the directory with some name like "out".

It happened with multiple SW products that I would build, but not
most.  Have no idea what caused it but do know that updating the
autoconf-related SW eventually made it go away.  Sorry can't be
more precise, but when I tried reporting it as a bug, different
dev-teams gave up and suggested re-formatting and re-installing 
linux.  So helpful!  

Occasionally I run into weird problems -- because of how my system
is setup -- but are still caused by bugs in the underlying SW --
like making perl, completely failed for a few years on my system
because I had a RAID 50 where the "optimal write size" was 12*64KB
(3 RAID-5's that were 4*64KB/stripe).  The underlying Gnu DB library
failed (probably still does, as no one wanted to try to fix it, 
was designed around the assumption that the optimal-write-size
would always be a power-of-2 -- which it is not.  

I even told how to reproduce and test for it (using a VM), but
it got ignored... ;^/

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list