gdb 7.11.1-2 started within emacs fails

William M. (Mike) Miller
Wed Oct 19 19:21:00 GMT 2016

On Wed, Oct 19, 2016 at 12:54 PM, Corinna Vinschen
<> wrote:
> On Oct 19 12:46, Rockefeller, Harry wrote:
>> >-----Original Message-----
>> >From: [mailto:cygwin->] On Behalf Of William M. (Mike) Miller
>> >Sent: Wednesday, October 19, 2016 10:30 AM
>> >To:
>> >Subject: Re: gdb 7.11.1-2 started within emacs fails
>> [snip]
>> >>>I can confirm that this happens also with gdb-7.11.1-1 but not
>> >>>gdb-7.10.1-1.  (I tested on x86_64, since gdb-7.10.1-1 is broken on x86.)
>> >>>It also fails with M-x gdb instead of M-x gud-gdb, but with a different error message:
>> >>>Failed to resume program execution (ContinueDebugEvent failed, error
>> >>>87) Ken
>> >>
>> >> I tried using 'ddd' instead of emacs and gdb aborts with the same readline ... message above.
>> >Any progress on the above issue? I recently updated my gdb and am running into the same problem.
>> >William M. (Mike) Miller | Edison Design Group
>> No progress I am aware of.  I switched over to 64-bit Cygwin which uses gdb-7.10.1-1 to avoid this problem.
>> This "request" may be related to the problem: I would like to see the autogenerated gdb line:
>> "---Type <return> to continue, or q <return> to quit---" to go away.
>> gdb pauses posting this line unnecessarily.

Thanks for the reference. I don't know why the OP thought that might
have been related to the gdb crash, but it didn't do anything to help
with that when I tried it.

William M. (Mike) Miller | Edison Design Group

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list