less.exe v481-1 cannot seek to EOF in CRLF file; current cygwin32, Win10 only.

staffanu staffan@ulfberg.se
Thu Sep 8 13:07:00 GMT 2016

>> ---------------------------------------------------
>> > > Any size larger than a few meg.  That is, any size that takes more
>> than
> a few
>> > > milliseconds to seek to the end, I think.
>> > 
>> > We will need someone with W10 to test it and confirm it.
>> > On W7 I have no issue at all with 250MB file
>> Tested on W10-64-cygwin-32 and a 207M-file, dos and unix-endings: both
>> behave the same, i.e. no error when pressing 'G' and display the last 
>> line. Was that the question?
>> cygwin 2.2.1, less 481
>> -Helmut
> I have reproduced on Win7, same exact cygwin, same exact symptom.
> OK, that you guys can't reproduce suggests that there is something special
> about my cygwin installation.  
> What is special, I suspect, is that I have not actually recreated it in
> many
> years: I just update it, and copy the whole thing from machine to machine. 
> (I
> described this in the attachment to my original email.)  That has worked
> well
> for a long time -- it is much easier and more consistent than running
> setup.exe on many machines.  But I suspect it has broken down.  Somehow, I
> may
> have old libs or old config files mixed with new.  (This last update, from
> 1.7
> to 2.3, is clearly a big one.)
> So, I will re-install cygwin from scratch on one machine, this weekend.
> In the meantime, put this bug report on hold.  Thanks to all of you.
> I will let the list know how this comes out.

Was this ever resolved? I have, I guess, the same problem. I cannot see that
the size of files matter, however -- I see the problem for all CRLF files 
that I tested. (It worked fine before upgrading a few days ago.)

The weird thing is that, moving the file with CRLF line endings to a binary
mounted filesystem makes less work just fine. Reading the file from a text
mounted filesystem results in the problem. Is not the point with text mounts
to be able to read text files with CRLF line endings?

Just as Karl, my Cygwin installation is very old -- i.e., any registry
entries (that I think might include mount options?) might have been written
10 years ago. Did the meaning of text/binary mounts change?


View this message in context: http://cygwin.1069669.n5.nabble.com/less-exe-v481-1-cannot-seek-to-EOF-in-CRLF-file-current-cygwin32-Win10-only-tp123813p129864.html
Sent from the Cygwin list mailing list archive at Nabble.com.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list