Windows 7 update broke Cygwin X?

Joshua Hoke
Mon Sep 12 13:01:00 GMT 2016

On Fri, Sep 9, 2016 at 1:17 PM, Joshua Hoke <> wrote:
> On Fri, Sep 9, 2016 at 12:42 PM, Marco Atzeri <> wrote:
>> On 09/09/2016 18:03, Joshua Hoke wrote:
>>> After a recent Windows update, I am unable to start Cygwin's X server
>>> anymore. I tried updating to the latest Cygwin by running setup again,
>>> /usr/bin/rebaseall and rebooting. There are no obvious errors from the
>>> X server if I run /usr/bin/startxwin from a Cygwin console, but it
>>> seems to exit after 20 seconds or so:

I tried following directions from for debugging with
strace and it seems there is an exception occurring inside a Trend
Micro DLL, causing XWin.exe to exit silently. At this point I don't
consider it a problem with Cygwin/X anymore, except that possibly it
should exit with a non-zero exit status. I am using a different X
server at the moment as a workaround.

Joshua Hoke

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list