gdb 7.11.1-2 started within emacs fails

Rockefeller, Harry Harry.Rockefeller@flightsafety.com
Thu Sep 29 17:24:00 GMT 2016


>-----Original Message-----
>From: cygwin-owner@cygwin.com [mailto:cygwin->owner@cygwin.com] On Behalf Of Ken Brown
>Sent: Tuesday, September 27, 2016 3:16 PM
>To: cygwin@cygwin.com
>Subject: Re: gdb 7.11.1-2 started within emacs fails

>On 9/27/2016 2:47 PM, Rockefeller, Harry wrote:
>> Using program foo:
>>       program foo
>>       e = 1.0
>>       stop
>>       end
>>
>> $ /usr/bin/gfortran    -g foo.f -o foo
>>
>> Emacs version info: GNU Emacs 25.1.1 (i686-pc-cygwin, GTK+ Version
>> 3.18.9) of 2016-09-17
>>
>> Inside emacs I ran M-x gud-gdb and got ... GNU gdb (GDB) (Cygwin
>> 7.11.1-2) 7.11.1 ...
>> (gdb) b 1
>> Breakpoint 1 at 0x4011d6: file foo.f, line 1.
>> (gdb) r
>> Starting program: /cygdrive/c/Users/harryr/foo.exe [New Thread
>> 6296.0x22ac] [New Thread 6296.0x24d4]
>> readline: readline_callback_read_char() called with no handler!
>> Debugger aborted (core dumped)
>>
>> Foo written in C++ also fails with the same message.
>> Running gdb foo in bash gives the expected result:
>> gdb stops at first executable line prompting for next gdb command.
>I can confirm that this happens also with gdb-7.11.1-1 but not gdb-7.10.1-1.  (I tested on x86_64, since gdb-7.10.1-1 is broken on x86.)
>It also fails with M-x gdb instead of M-x gud-gdb, but with a different error message:
>Failed to resume program execution (ContinueDebugEvent failed, error 87)
>Ken

I tried using 'ddd' instead of emacs and gdb aborts with the same readline ... message above.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list